Buy Now Buy Now *mycrysis-interstitial-content*
  • Author
    Message
    Posted
  • Subject: Crysis 1.2 patch retail doesn't work, error 1642

    i7 950, 6 gigs of ram, windows 7, gtx 460 1gb, SSD drive main, two additional normal hardrives for games.

    Long time fan, first time posting here. I don't have any crysis 2 demo installed, I moved my installation path to the D: drive where I custom installed crysis 2. I'm using windows 7 and I bought the game from retail. I am using avast antivirus, but I don't think that matters. My problem is for the retail version, I am having trouble installing a patch. I noticed in the past with most games like crysis warhead, I had to patch it in the C: folder, maybe it's an EA thing but I have a SSD drive which obviously can't fit all these EA games due to it's capacity. I usually have to copy it to C: patch it then move it back to D: Look I belive I have the right to install it to any folder and no one can say you only have to install it in C: drive, I mean there is a custom option for install right?

    The problem i'm having today is even though the game is at the D: folder, I can't patch the game. I wish now I bought the steam version which would be less of a problem. I tried to contact EA, they said run it as admin or maybe turn off some user control thing in windows 7. I tried everything but I can't get the game to install. I tried manually using 1.1 patch and it told me it's already installed. I mean the game updated it to 1.1 before I finished my installation. Crysis 2 is at least under my control panel uninstall folder at least, even if it's in the D: drive. I find it funny how EA or crysis expects everyone to run their games on C: drive, it's not always possible with SSD drives and space concerns. Is anyone else getting this error?

    Should I copy the folder onto the C: drive and try the patch again? or should I reinstall? I don't want to reinstall the game for every patch. I want it patch so I can use the nano catylast which keeps resetting after every level or not work at all. Also I heard it's good for the multiplayer since I haven't played it yet. Can anyone give me any info or if they have the same error and what can be done about it without reinstalling the game. I don't want to lose activation limits and I was debating whether I should of bought it on steam or retail, now I know I have made a mistake because I had problems in the past patching specificially EA games and crysis warhead too because I can't choose where I patch, the patch to unlike other patches i've dealt with which will let you choose the folder or program at least. I want to raise awareness of the issue and maybe others are having the same problem with the retail version. I don't know because I can't find any info of problems directly relating to this patch. Thank you for any replies. I hope I wrote it in the right section of the forum and the right ppl making the game can see this and maybe offer a solution. Thanks.
    Attachments
    error.jpg
    the screenshot of the error
    05 Apr 2011, 07:26
  • Subject: Re: Crysis 1.2 patch retail doesn't work, error 1642

    I just found the solution to my own problem. I just opened the crysis launcher and then it just patched the game for me. Good idea crytek, that adresses my patching problems. Sorry for panicking, no one really answered my question and they probally all already know how to do this except me. Feel free to close the thread or delete it. Thank you anyways, I am happy to be running crysis 2 1.2 now. I hope it fixes the nano catylast problem that keeps dissapearing.
    05 Apr 2011, 08:00
  • Subject: Re: Crysis 1.2 patch retail doesn't work, error 1642

    Okay, i'm launching the patch 1.2 now, the problem was I didn't want my nano catylast to be at 0 all the time. It still didn't fix it and I don't find that fair. I can't ever max out my suit abilities if they don't give me credit for the nano catylast.

    I have posted 2 screenshots of the same location to show my point. I am standing by two desk here, I just got 20 nano catylast points, yet I still get 0 all the time regardless which gives me no credit for it. Other times it might take like alot of points just to get the counter going again, then it just resets after the next level.

    The first image of me squishing the bug, http://img43.imageshack.us/i/crysis2201 ... 40014.jpg/ the next one is attached showing I got no credit for it. If this can be adressed, it will be more fair. If I am posting this at the wrong section of the forum, you can lock or delete this thread, but I just wanted to bring this to your attention. At the time I was really worried I couldn't get it to work, thanks anyways.

    Edit: i've been able to get the counter going again after killing alot of the aliens. Not sure if it's going to stay after the next level, but I have been able to get the counter going again. Maybe the patch didn't fix the problem, i'll keep testing it to find out.

    Edit again: so far after the counter started again with the nano catylast, I was still able to retain it for a few levels. So maybe the problem i'm having is resolved.
    Attachments
    Crysis2 2011-04-05 03-14-08-08.jpg
    05 Apr 2011, 08:20

ESRB Video Game Rating

This title is rated Mature for:

  • Blood
  • Partial Nudity
  • Strong Langague
  • Violence
cron